CCNA 200-125 Exam: EIGRP Questions With Answers

CCNA 200-125 Exam: EIGRP Questions With Answers

  1. A network administrator is troubleshooting an EIGRP problem on a router and needs to confirm the IP addresses of the devices with which the router has established adjacency. The retransmit interval and the queue counts for the adjacent routers also need to be checked. What command will display the required information?
    • A. Router# show ip eigrp neighbors*
    • B. Router# show ip eigrp interfaces
    • C. Router# show ip eigrp adjacency
    • D. Router# show ip eigrp topology

    Show (Hide) Explanation/Reference
    Below is an example of the “show ip eigrp neighbors” output.

    Let’s analyze these columns:

    H: lists the neighbors in the order this router was learned
    Address: the IP address of the neighbors
    + Interface: the interface of the local router on which this Hello packet was received
    Hold (sec): the amount of time left before neighbor is considered in “down” status
    Uptime: amount of time since the adjacency was established
    SRTT (Smooth Round Trip Timer): the average time in milliseconds between the transmission of a packet to a neighbor and the receipt of an acknowledgement.
    RTO (Retransmission Timeout): if a multicast has failed, then a unicast is sent to that particular router, the RTO is the time in milliseconds that the router waits for an acknowledgement of that unicast.
    Queue count (Q Cnt): shows the number of queued EIGRP packets. It is usually 0.
    Sequence Number (Seq Num): the sequence number of the last update EIGRP packet received. Each update message is given a sequence number, and the received ACK should have the same sequence number. The next update message to that neighbor will use Seq Num + 1.

    In this question we have to check the RTO and Q cnt fields.

  2. Which option describes a difference between EIGRP for IPv4 and IPv6?
    • A. Only EIGRP for IPv6 advertises all connected networks.
    • B. Only EIGRP for IPv6 requires a router ID to be configured under the routing process*
    • C. AS numbers are configured in EIGRP but not in EIGRPv3.
    • D. Only EIGRP for IPv6 is enabled in the global configuration mode.

    Show (Hide) Explanation/Reference
    To configure EIGRP for IPv6 we must explicitly specify a router ID before it can start running. For example:

    ipv6 router eigrp 1 
    eigrp router-id 2.2.2.2 
    no shutdown

    EIGRPv3 also uses the AS number (for example: ipv6 eigrp 1 under interface mode).Notice that EIGRP for IPv6 router-id must be an IPv4 address. EIGRP for IPv4 can automatically pick-up an IPv4 to use as its EIGRP router-id with this rule:

    + The highest IP address assigned to a loopback interface is selected as the router ID.

    + If there are not any loopback addresses configured, the highest IP address assigned to any other active interface is chosen as the router ID

  3. Which EIGRP for IPv6 command can you enter to view the link-local addresses of the neighbors of a device?
    • A. show ipv6 eigrp 20 interfaces
    • B. show ipv6 route eigrp
    • C. show ipv6 eigrp neighbors*
    • D. show ip eigrp traffic

    Show (Hide) Explanation/Reference
    The “show ipv6 eigrp neighbors” command displays the neighbors discovered by the EIGRPv6. Notice that the neighbors are displayed by their link-local addresses.

  4. Which function allows EIGRP peers to receive notice of implementing topology changes?
    • A. successors
    • B. advertised changes
    • C. goodbye messages*
    • D. expiration of the hold timer

    Show (Hide) Explanation/Reference
    The goodbye message is a feature designed to improve EIGRP network convergence. The goodbye message is broadcast when an EIGRP routing process is shutdown to inform adjacent peers about the impending topology change. This feature allows supporting EIGRP peers to synchronize and recalculate neighbor relationships more efficiently than would occur if the peers discovered the topology change after the hold timer expired.

    The following message is displayed by routers that run a supported release when a goodbye message is received:

    *Apr 26 13:48:42.523: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.1.1 (Ethernet0/0) is down: Interface Goodbye received

    Reference: http://www.cisco.com/c/en/us/td/docs/ios/12_2/ip/configuration/guide/fipr_c/1cfeigrp.html

    Note: In this question we should understand “impending”, not “implementing” as there are no correct answers with “implementing” topology change.

  5. What are the address that will show at the “show ip route” if we configure the above statements? (Choose three)
    router eigrp 100
    network 172.15.4.0
    network 10.4.3.0
    network 192.168.4.0
    auto-summary
    • A. 10.0.0.0*
    • B. 10.4.3.0
    • C. 172.15.4.0
    • D. 172.15.0.0*
    • E. 192.168.4.0*
    • F. 192.168.0.0

    Show (Hide) Explanation/Reference
    With auto-summary feature is turned on, EIGRP will summary these networks to their classful networks automatically. For example:

    + 172.15.4.0 belongs to class B so it will be summarized to 172.15.0.0
    + 10.4.3.0 belongs to class A so it will be summarized to 10.0.0.0
    + 192.168.4.0 belongs to class C so it will be summarized to 192.168.4.0 (same)

  6. What does split horizon prevent?
    • A. routing loops, link state
    • B. routing loops, distance vector*
    • C. switching loops, STP
    • D. switching loops, VTP

    Show (Hide) Explanation/Reference
    Split horizon is used in distance vector routing protocols (like RIP, EIGRP) to prevent routing loops by prohibiting a router from advertising a route back to the interface from which it was learned.
  7. What is called when variance with two times of metric?
    • A. unequal cost load balancing*
    • B. path selection
    • C. equal cost load balancing
    • D. other

    Show (Hide) Explanation/Reference
    EIGRP provides a mechanism to load balance over unequal cost paths (or called unequal cost load balancing) through the “variance” command. In other words, EIGRP will install all paths with metric < variance * best_metric into the local routing table, provided that it meets the feasibility condition (to prevent routing loop). The feasibility condition states that, the Advertised Distance (AD) of a route must be lower than the feasible distance of the current successor route.
  8. Which feature is config by setting a variance that is at least 2 times the metric?
    • A. unequal cost load balancing*
    • B. path selection
    • C. equal cost load balancing
    • D. path count

    Show (Hide) Explanation/Reference
    EIGRP provides a mechanism to load balance over unequal cost paths (or called unequal cost load balancing) through the “variance” command. In other words, EIGRP will install all paths with metric < variance * best_metric into the local routing table, provided that it meets the feasibility condition (to prevent routing loop). The feasibility condition states that, the Advertised Distance (AD) of a route must be lower than the feasible distance of the current successor route.
  9. Refer to the exhibit. Based on the exhibited routing table, how will packets from a host within the 192.168.10.192/26 LAN be forwarded to 192.168.10.1?

    • A. The router will forward packets from R3 to R2 to R1
    • B. The router will forward packets from R3 to R1
    • C. The router will forward packets from R3 to R1 to R2
    • D. The router will forward packets from R3 to R2 to R1 AND from R3 to R1*

    Show (Hide) Explanation/Reference
    From the routing table we learn that network 192.168.10.0/30 is learned via 2 equal-cost paths (192.168.10.9 &192.168.10.5) -> traffic to this network will be load-balancing.
  10. Which two statements about EIGRP on IPv6 device are true? (Choose two)
    • A. It is configured on the interface*
    • B. It is globally configured
    • C. It is configured using a network statement
    • D. It is vendor agnostic
    • E. It supports a shutdown feature*

    Show (Hide) Explanation/Reference
    This is an example of how to configure EIGRP for IPv6:

    interface Serial0/0 
    no ip address 
    ipv6 address FE80::1 link-local 
    ipv6 address 2010:AB8::1/64 
    ipv6 enable 
    ipv6 eigrp 1 
    ! 
    ipv6 router eigrp 1 
    eigrp router-id 2.2.2.2 
    no shutdown

    As you can see, EIGRP for IPv6 can only be enabled under each interface -> A is correct.

    Under EIGRP process there is a shutdown feature where you can turn on or off -> E is correct.

  11. If R1 is configured as shown, which three addresses will be received by other routers that are running EIGRP on the network? (Choose three)
    R1(config)#router eigrp 103
    R1(config-router)#network 10.4.3.0
    R1(config-router)#network 172.16.4.0
    R1(config-router)#network 192.168.2.0
    R1(config-router)#auto-summary
    • A. 172.16.4.0
    • B. 10.0.0.0*
    • C. 172.16.0.0*
    • D. 192.168.2.0*
    • E. 192.168.0.0
    • F. 10.4.3.0

    Show (Hide) Explanation/Reference
    These networks will be summarized to the major networks of that class so:
    + 10.4.3.0 belongs to class A -> It will be summarized into 10.0.0.0
    + 172.16.4.0 belongs to class B -> It will be summarized into 172.16.0.0
    + 192.168.2.0 belongs to class C -> It will be summarized into 192.168.2.0 (not changed)
  12. Which routing protocols are compatible with stubs? (Choose two)
    • A. OSPF*
    • B. EIGRP*
    • C. EGP
    • D. BGP
    • E. IS-IS
    • F. RIP

Related Articles

Leave a Reply